Darron J. Schall
darron at darronschall.com
Mon Feb 7 13:28:26 PST 2005
> Hmm.. good idea. My preference would be Command implements ICommand
> and RemotingCommand imeplements ICommand.. then your command would
> extend either Command or RemotingCommand based on it's need.
Just to clarify - "RemotingCommand" is the wrong term.. Naming it more
correctly would be "RemoteCommand" or "ServerCommand" or
"CommandWithServerInteraction" or soemthing along those lines.
In my current project.. I have remote commands that are web services,
some that are remoting, and I wrote a custom "FCService" class that uses
LoadVars to send form data and process results, but with the same
interface (i.e. returns a PendingCall, calls onResult, etc).
So, yeah, 3 types of "Remote" commands, but not all "Remoting"
commands. Sorry for the confusion, if any.
More information about the Arp